
Kapitola 5

Kouzla s textem
Úpravy textu jsou po úpravách fotografi í nejvíce používané techniky, a proto jim věnujeme 
samostatnou kapitolu. Pro jednoduché úpravy textu jsou ve Photoshopu připravené styly vrs-
tev, pomocí kterých vytvoříte profesionální nadpisy, a text zůstane po celou dobu práce plně 
editovatelný. I při různých deformacích textu nenajdete lepšího pomocníka, než je Photoshop. 
Ne každá deformace ale pracuje stejně s každou velikostí a typem fontu. Proto je v následujících 
příkladech vždy uvedena velikost, typ a řez fontu, který je pro konkrétní příklad nejvhodnější. 

Přednastavení vlastností textu
Jednoduchý, ale užitečný, způsob, jak si ulehčit a zpřehlednit používání nástroje Písmo (Type Tool), 
je uložení jeho vlastností do paletky Přednastavené nástroje (Tool Presets). Sem můžete ukládat 
vlastnosti a nastavení i ostatních nástrojů, ale u nástroje Písmo se nám to výborně hodí. Navrhu-
jete například internetové stránky a máte na tlačítkách, v nadpisech 
a v textu rozdílné typy fontů a velikosti písma. Po nějaké době je 
potřeba stránky upravit (rozšířit) a vy si marně snažíte vzpomenout, 
jaká kombinace byla nejvhodnější. Právě k tomu je dobré uložit si 
nastavení písma a pak jej jednoduše znovu používat.

1. Zvolte nástroj Písmo (Type Tool) a na panelu nástrojů 
v horní části pracovní plochy nastavte požadovaný typ, 
velikost písma, jeho barvu a případně i jiná nastavení.

2. Otevřete paletku Přednastavené nástroje (Tool Presets) 
a klepněte na ikonu Vytvořit nový přednastavený nástroj (Create New Tool Preset).

3. Otevře se dialogové okno, do kterého je potřeba napsat pojmenování tohoto nastavení. 
Automaticky se nastavení pojmenuje typem a velikostí písma, kdo by si ale takovou kom-
binaci do budoucna pamatoval? Daleko lepší je pojmenovat nastavení názvem projektu 
a místem, kde bylo použito. Například květinářství-nadpis, nebo květinářství-text.

Pak už stačí jen klepnout v paletce Přednastavené nástroje (Tool Presets) na příslušnou řádku 
a písmo bude vždy takové, jaké jste chtěli mít.

Obtékání textu
V textových editorech a vektorových programech, kde je kladen důraz na práci s textem, je 
standardní funkcí vlévání textu do různých tvarů a obtékání obrázků textem. Photoshop sice 
není textový editor, přesto jsou jeho textové funkce velmi pokročilé. Pokud spojíte vektorové 

Obrázek 5.1 Paletka 
Přednastavené nástroje 
(Tool Presets)
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tvary s textovým nástrojem, dosáhnete překvapivých výsledků. Ukážeme si, jak psát text tak, 
aby obtékal obrázek:

1. Vytvořte nový dokument 500 × 350 pixelů. 
2. Nejprve si do prázdného dokumentu vložíme obrázek, který necháme obtékat textem. 

Já jsem použil vektorovou kresbu, která je k dispozici mezi vektorovými tvary nástroje 
Custom Shape Tool.

3. Funkce, která by zajistila automatické obtékání obrázku textem, ve Photoshopu chybí. 
Proto ji musíme nahradit vhodnou kombinací vektorových tvarů, které vytvoří obálku 
pro vložení textu. Zvolte nástroj pro výběr (Rectangle Tool). Na panelu nástrojů klepněte 
na ikonu Cesta (Path). Tím máme zajištěno, že se nakreslená cesta nevyplní barvou. 

4. Umístěte kurzor myši do levého horního 
rohu a stiskněte levé tlačítko myši a tažením 
do protilehlého rohu nakreslete obdélník. 
Do tohoto obdélníku později vepíšeme 
text. 

5. Změňte nástroj na Elipsa (Ellipse Tool) 
a na panelu nástrojů navíc klepněte na iko-
nu Substract to Shape Area. To způsobí, že 
každý další vektorový tvar, který nakreslíte, 
se odečte od předchozího. Elipsu jsem zvo-
lil proto, abych co nejlépe ohraničil obrázek 
uprostřed dokumentu. 

6. Elipsu nakreslíte tak, že stisknete kurzor myši uprostřed horní části obdélníku a tažením 
směrem dolů a trochu doprava vytvoříte elipsu. Pozor! Elipsa musí protínat horní hranu 
obdélníku. Tím vytvoříte v původním obdélníku jakýsi výřez.

K přesnému umístění elipsy kolem obrázku 
použijte klávesu mezerník. Když mezerník stisk-
nete, budete místo kreslení s elipsou pohybovat. 
Po uvolnění můžete pokračovat v kreslení.

7. Obdélník s elipsovitým výřezem nám bude 
tvořit obálku, do které můžeme vepsat, 
nebo zkopírovat text.

8. Zvolte nástroj Písmo (Type Tool) a kurzor 
myši umístěte dovnitř obdélníku. Všimněte 
si, že se tvar kurzoru změnil. Kolem známé-
ho I se vytvořil kroužek. Ten nám říká, že se 
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Obrázek 5.2 Nastavení nástroje pro nakreslení obdélníku

Obrázek 5.3 Ohraničení textu (text box)

Obrázek 5.4 Nastavení nástroje pro nakreslení elipsy

Obrázek 5.5 Obdélník s odečtenou elipsou
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nacházíme uprostřed vektorového tva-
ru, do kterého lze umístit text. Klepně-
te myší a začněte psát. Kurzor myši se 
automaticky umístí do levého horního 
rohu. Při psaní se text před obrázkem 
přeruší a pokračuje až za ním do té 
doby, než překročí spodní část elipsy. 
Pak už pokračuje zleva doprava, jako 
při normálním psaní. 
Když budete potřebovat, aby text tvořil 
kolem obrázku dva sloupce, to znamená, že 
text vyplní nejprve levou stranu a pak tepr-
ve pokračuje vpravo od obrázku, musíte při 
kreslení elipsy protnout i spodní hranu obdélníku. Tím vytvoříte dvě nezávislé obálky, které ale 
musíte každou zvlášť naplnit textem. Ten se mezi nimi automaticky nepřelévá.

Neonová trubice
Mezi jednoduché, ale vděčné úpravy písma patří napodobení neonové trubice. Nejlepšího 
výsledku dosáhnete v kombinaci s použitím vhodného fontu, který je sám o sobě tvořen zakři-
venými čarami.

1. Otevřete nový dokument 300 × 150 pixelů 
s bílým pozadím a nástrojem Písmo (Type 
Tool) do něj vepište černý text.

2. Zvolte efekt Rozostření → Gaussovské 
rozostření (Blur → Gaussian Blur) s hod-
notou rozostření 1,8. Budete varováni, že 
efekt se dá použít pouze na rastrový obrá-
zek. Stisknutím tlačítka OK se text převede 
z vektorové na rastrovou grafi ku. Okraje 
textu se rozostří.

3. Příkazem Vrstva → Sloučit (Layer → Flaten 
Image) spojte textovou vrstvu s pozadím.

4. Příkazem Obraz → Přizpůsobit → Inverze (Image → Adjust → Invert) změníme obrá-
zek černé pozadí s bílým textem.

5. A teď to hlavní. Filtrem Filtr → Stylizace → Solarizace (Filter → Stylize → Solarize) 
zdvojíme okraje textu.

6. Příkazem Obraz → Přizpůsobit → Úrov-
ně automaticky (Image → Adjust → Auto 
Levels) zvýšíme kontrast textu.

7. Nakonec upravíme barvu vzniklé neonové 
trubice nastavením Obraz → Přizpůsobit 
→ Vyvážení barev (Image → Adjust → 
Color Balance) například na fi alovou (+100, 
-100, +100).

Neonová trubice 173

Obrázek 5.6 Text obtéká obrázek

Obrázek 5.7 Základní text pro neonový 
nápis

Obrázek 5.8 Neonový nápis
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Výbušný text
Výbuch textu a jeho rozmetání do všech stran nejlépe vynikne s tučným textem, tvořeným pou-
ze obvodovými křivkami. Takový text se dá vytvořit z libovolného typu fontu.

1. Otevřete nový dokument 400 × 150 s černým pozadím a nástrojem Písmo (Text Tool) do 
něj vepište bílý text fontem Balloon.

2. Zvolte efekt Rozostření → Gaussovské rozostření (Blur → Gaussian Blur) s hodnotou 
rozostření 2,2. Budete varováni, že efekt se dá použít pouze na rastrový obrázek. Stisknu-
tím tlačítka OK se text převede z vektorové na rastrovou grafi ku. Okraje textu se rozostří.

3. Filtrem Filtr → Stylizace → Solarizace (Filter → Stylize → Solarize) zdvojíme okraje 
textu a příkazem Obraz → Přizpůsobit → Úrovně automaticky (Image → Adjust → 
Auto Levels) zvýšíme jeho kontrast.

4. Textovou vrstvu je pro následující operace potřeba sloučit se základní vrstvou příkazem 
Vrstva → Sloučit (Layer → Down).

5. V paletce Vrstvy (Layers) klepněte na základní vrstvu (nyní obsahuje pozadí i text) pravým 
tlačítkem myši a z kontextového menu zvolte příkaz Duplikovat vrstvu (Duplicate Layer). 
Tím vytvoříte kopii (Background copy), kterou později použijeme ke zvýraznění textu.

6. Vyberte znovu základní vrstvu 
a proveďte úpravu fi ltrem Fil-
tr → Deformovat → Polární 
souřadnice (Filter → Distort 
→ Polar Coordinates) nastave-
ným na Polar to Rectangular. 
Filtr zdeformuje text jako by ho 
chtěl přizpůsobit tvaru koule. 

7. Pro použití dalšího fi ltru je 
potřeba dokument pootočit 
příkazem Obraz → Natočit 
plátno → O 90° vpravo (Image 
→ Rotate Canvas → 90° CW). 
Filtr Stylizace → Vítr (Stylize 
→ Wind) totiž pracuje pou-
ze ve vodorovném směru. Pro 
znásobení efektu použijte fi ltr 
dvakrát po sobě. Tím docílíte 
roztažení a zašpičatění zdefor-
movaného textu.

8. Natočte dokument do původ-
ní polohy příkazem Obraz → 
Natočit plátno → O 90° vlevo 
(Image → Rotate Canvas → 90° CCW) a také změňte souřadnicové zobrazení zpět na 
pravoúhlé fi ltrem Filtr → Deformovat → Polární souřadnice (Filter → Distort → Polar 
Coordinates) nastaveným na Rectangular to Polar.

9. Text se vrátí do své původní podoby a kolem něj vznikly záblesky výbuchu. Pro zvýšení 
efektu je dobré paprsky (i text) zabarvit oranžovou barvou příkazem Obraz → Přizpů-
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Obrázek 5.9 Deformace textu – Polární souřadnice

Obrázek 5.10 Deformace textu – Vítr
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sobení → Odstín a sytost (Image → Adjust → Hue/Saturations) – Kolorovat nastave-
ným na Odstín: 40, Sytost: 70.

Výbuch je hotový, ale původní text 
v něm trochu zaniká. V průběhu 
úprav jsme si vytvořili kopii základ-
ní vrstvy a tu teď použijeme pro 
zvýraznění textu. V paletce Vrstvy 
klepněte na kopii vrstvy a nastavte 
její interakci s následující vrstvou na 
Režim: Zesvětlit (Mode:Lighten). 
Obrys textu se zjasní a bude lépe 
čitelný.

Vyplnění textu obrázkem
Pro zvýraznění textu na jednobarevném pozadí lze použít výplň textu vhodným obrázkem. 
Obrázek by měl být tak velký, aby zasahoval přes celou plochu textu. Jako příklad můžeme 
použít ukázkový obrázek Fish.psd. Ten má dostatečně jemný motiv (malé rybky) na to, aby byl 
rozeznatelný na všech písmenech textu. Původní obrázek je složen z osmi samostatných vrstev. 
To by nám mohlo dělat potíže, a tak si nejprve vytvoříme kopii obrázku s jednou vrstvou, která 
bude obsahovat vše (také můžete použít nějaký vhodný vlastní obrázek).

1. Zvolte příkaz Obraz → Duplikovat (Image → Duplicate). V dialogovém okně pak 
označte volbu Duplicate Merged Layers Only. Tím vytvoříte kopii obrázku (původní 
zůstane nezměněn) sloučenou do jedné samostatné vrstvy.

2. Zvolte nástroj Písmo (Type Tool) Arial Black 120pt, klep-
něte v levé části obrázku a napište text.

3. Pomocí nástroje Posun (Move Tool) umístěte nápis tak, 
aby byl celý na ploše obrázku (případně změňte velikost 
písma).

4. Proveďte výběr z textové vrstvy klepnutím na náhled vrst-
vy (v paletce Vrstvy) se stisknutou klávesou Ctrl.

5. Zvolte jako aktivní vrstvu s obrázkem a zvolte příkaz Vrst-
va → Maska vrstvy → Odkrýt výběr (Layer → Layer 
Mask → Reveal Selection). Tím se u vrstvy vytvoří maska, 
která skryje obrázek a zviditelní pouze 
text. 

6. Skryjte původní textovou vrstvu (klepnu-
tím na ikonku oka v levé části paletky 
Vrstvy (Layers).

Na obrázku zůstane pouze text (pro zvýšení 
kontrastu jsem jej umístil na bílé pozadí) tvoře-
ný podkladovým obrázkem. 

Vyplnění textu obrázkem 175

Obrázek 5.11 Výbušný text

Fish.psd

Obrázek 5.12 Maska 
u vrstvy s obrázkem

Obrázek 5.13 Text vyplněný obrázkem
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Editace textu s obrázkem
Předchozí způsob textu s maskou má výhodu v dodatečné možnosti přesně umístit polohu textu 
na obrázku.

1. Klepněte v paletce Vrstvy (Layers) postupně na ikonku řetězu mezi náhledem vrstvy 
s obrázkem a maskou vrstvy a pak na náhled masky (náhled se zvýrazní bílým ohraniče-
ním). Tím dočasně oddělíte původní obrázek od masky. 

2. Pomocí nástroje Posun (Move Tool) můžete nyní volně pohybovat maskou po obrázku 
a přesně tak umístit polohu nápisu.

3. Pro opětovné spojení vrstvy 
a masky klepněte do místa, 
kde byla ikonka s řetězem.

4. Když jste s umístěním tex-
tu spokojeni, můžete editaci 
ukončit tím, že necháte mas-
ku promítnout do obrázku 
příkazem Vrstva → Maska 
vrstvy → Použít (Layer → 
Layer Mask → Apply).

Tím se na obrázku na první pohled 
nic nezměnilo, ale od této chvíle je 
text s obrázkem defi nitivně samo-
statnou vrstvou

Trojrozměrný text
Na efekt, který působí prostorovým dojmem u textu, není v Photoshopu žádný fi ltr. Proto si jej 
musíme vytvořit sami. Není to nic těžkého, jen se někomu postup může zdát trochu zdlouhavý. 
Na začátku si připravíme nový, čistý, dokument velikosti 600 × 400 px.

1. Zvolte nástroj Písmo (Text Tool) a vepište text.
2. Text změňte na obrázek příkazem Vrstva → Rastrovat → Písmo (Layer → Rasterize → 

Type).
3. Aby text vypadal skutečně prostorově, bude lepší trochu jej upravit. Zvolte příkaz Úpra-

vy → Transformace → Deformace (Edit → Transform → Distort). Text upravíme tak, 
aby vypadal, že padá směrem dozadu. 

Obrázek 5.14 Aktivní 
maska vrstvy

Obrázek 5.15 Samostatná 
vrstva s textem

Obrázek 5.16 Transformace textu Obrázek 5.17 Kopie vrstvy
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177Trojrozměrný text

4. Pokud jste si jistí, že je podoba textu defi nitivní, vytvořte kopii vrstvy s textem příkazem 
Vrstva → Nová → Vrstva kopírováním (Layer → New → Layer Via Copy). V paletce 
Vrstvy (Layers) přibude nad původní vrstvou kopie vrstvy, kterou přetažením posuňte 
pod vrstvu s textem.

5. Kopii vrstvy je v tuto chvíli potřeba přebarvit na jinou barvu, než původní text. To pro-
vedete jednoduše tak, že změníte barvu popředí na černou a nástrojem Spojitá výplň 
(Paint Busket Tool) klepnete v obrázku na kopii textu.

6. Kopie vrstvy bude tvořit třetí rozměr textu, a proto ji 
v obrázku musíme posunout směrem dolů. Zvolte nástroj 
Posun (Move Tool) a jednou stiskněte kurzorovou šipku 
„dolů“ na klávesnici. Text se posune směrem dolů o jeden 
pixel a pod původním textem se vytvoří . 

Nyní už záleží jen na vás, jak hluboký text potřebujete vytvořit. 
Každá další kopie vrstvy posunutá o jeden pixel zvýší dojem pro-
storovosti. Při osmi vrstvách bude text hluboký osm pixelů, tak 
jako na obrázku. 

Pokud potřebujete získat mnohem 
větší hloubku textu, nekopírujte done-
konečna jednotlivé vrstvy pod sebe. 
Označte v paletce Vrstvy (Layers) všech 
osm kopií (klepněte na první kopii a se 
stisknutou klávesou SHIFT na poslední) 
a zvolte příkaz Vrstva → Sloučit (Layer 
→ Merge Down). Všechny vrstvy se tak 
spojí do jedné. Pak udělejte kopii slou-
čené vrstvy a posuňte ji směrem dolů 
o stejný počet pixelů, z kolika vrstev 
byla vrstva složena (v našem případě 
o osm). Takto bude vypadat text s další-
mi třemi vrstvami. 

Obrázek 5.18 3D-text Obrázek 5.19 Osm kopií 
vrstev

Obrázek 5.20 Znásobená hloubka textu
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Vystínování trojrozměrného textu
Prostorový dojem textu v předchozím příkladu působí trochu uměle, protože mu chybí přiroze-
né nasvícení a stíny na svislých plochách. Pro jejich zvýraznění použijeme fi ltr, který pracuje na 
principu napodobení dopadajícího světla, a s jeho pomocí dodáme textu přirozený vzhled.

1. Zvolte jako aktivní vrstvu, ve které je spodní, vytažená, část textu.
2. Vyberte efekt Filtr → Vykreslení → Světelné efekty (Filter → Render → Lighting Eff ects).
3. Vlastnosti fi ltru se nastavují v samostatném okně s náhledem. Do náhledu je v našem 

případě potřeba umístit 
čtyři světla typu Spot-
light. Světla jsem umístil 
tak, aby osvětlovala levé 
spodní hrany svislých 
ploch. 

4. Nová světla přidáte 
vytažením žárovky ze 
spodní části okna do 
náhledu. V pravé části 
okna upravte intenzi-
tu světla v závislosti na 
velikosti textu tak, aby 
každé světlo osvětlova-
lo pouze jednu hranu 
a nezasahovalo do plo-
chy celého textu.
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Obrázek 5.21 Rozmístění světel

Obrázek 5.22 Nastavení stylu vrstvy
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5. Stisknutím tlačítka OK potvrdíte správnost nastavení a fi ltr se přenese do obrázku.
Horní část textu také zvýrazníme, ale mnohem jednodušším způsobem, za pomoci stylů vrstev:

1. Zvolte jako aktivní vrstvu s původním textem.
2. Ve spodní části paletky Vrstvy 

(Layers) klepněte na ikonu Přidat 
styl vrstev (Add a layer style) a ze 
seznamu zvolte Překrýt přechodem 
(Gradient Overlay). Tento styl nám 
původní text pokryje barevným pře-
chodem.

3.  Barevný přechod nastavíme od tmavé 
barvy přes světlou opět k tmavé, aby 
se současně zvýraznila spodní i horní 
hrana. 

Výsledkem našeho snažení bude vystínova-
ný text. 

Prolnutí textu do pozadí
Umístit text na pozadí tak, aby v textu vynikla textura pozadí, nám umožní příkaz Blending 
Options z kontextové nabídky vrstvy v paletce Vrstvy (Layers).

1. Otevřete obrázek stopy.jpg z doprovodného CD.
2. Zvolte nástroj Písmo (Text Tool) a vepište 

do obrázku nějaký text (nejlépe tučným 
fontem velikosti 120 px) bílou barvou.

3. Klepněte na textovou vrstvu v paletce Vrst-
vy (Layers) pravým tlačítkem myši a z kon-
textového menu vyberte příkaz Blending 
Options.

4. Příkaz otevře okno, ve kterém vidíte ve 
spodní části dva posuvníky s bílými 
a černými jezdci. Když budete pohy-
bovat bílým jezdcem směrem dole-
va, bílý text po chvíli zmizí. Když 
budete naopak pohybovat černým 
jezdcem směrem doprava, bude se 
text postupně rozpadat v místech, 
kde jsou pod ním tmavé plochy 
pozadí.

5. Umístěte kurzor myši nad černý jez-
dec a stiskněte současně levé tlačít-
ko myši a klávesu Alt. Pak posuňte 
jezdec směrem doprava. Jezdec se 
rozdělí na dvě poloviny. Umístěte 
jezdce do polohy podle obrázku. 
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Obrázek 5.23 Vystínovaný text

stopy.jpg

Obrázek 5.25 Prolnutý text do pozadí

Obrázek 5.24 Rozdělení a nastavení jezdců
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Tak dosáhnete prolnutí tmavých míst podkladu do textu v rozsahu polotónů určených krajními 
polohami jezdců. 

Čím více vpravo umístíte pravou polovinu černého jezdce, tím bude text průhlednější (více se 
prolne do pozadí). Podle druhu a barvy pozadí můžete pro dokonalé prolnutí stejným způso-
bem rozdělit a nastavit i bílý jezdec.

Poškozený text
Na tomto jednoduchém příkladu si ukážeme, jak vyrobit poškození, způsobené „zubem času“, 
pomocí fi ltru Oblaka (Clouds). Lze jej použít například pro napodobení odloupané barvy 
z nějakého nápisu.

1. Vytvořte nový dokument 500 × 200 pixelů.
2. Nástrojem Písmo (Text) vepište nějaký text, nejlépe do celé plochy dokumentu. Barvu 

textu zvolte bílou.
3. Přidejte do dokumentu novou vrstvu příkazem Vrstva → Nová (Layer → New). V dialo-

govém okně nové vrstvy označte volbu Použít předcházející vrstvu k vytvoření ořezové 
masky (Use Previous Layer to Create Clipping Mask). Tím vytvoříte z předchozí textové 
vrstvy masku. 

4. Zvolte fi ltr Filtr → Vykreslení → Oblaka (Filter → Render → Clouds). Nová vrstva se 
vyplní texturou mraků, ale protože jsme z předchozí vrstvy vytvořili masku, jsou vypl-
něna pouze písmena textu.

5. Nyní nastává chvíle pro trochu 
experimentování. Zvolte pří-
kaz Obraz → Přizpůsobit → 
Práh (Image → Adjustments 
→ Th reshold). Potřebujeme, 
aby se textura mraků změnila 
na černé a bílé plochy. Posunuj-
te jezdec ve spodní části panelu 
doprava, nebo doleva tak, aby 
bílé plochy nebyly moc velké 
a nezničily tak většinu textu 
(text musí zůstat čitelný). 
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Obrázek 5.26 Vytvoření masky

Obrázek 5.27 Nastavení prahu (Threshold)
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6. Klepněte pravým tlačítkem myši na tex-
tovou vrstvu a z kontextového menu 
vyberte příkaz Volby prolnutí (Blending 
Options). Ve spodní části panelu pohy-
bujte bílým jezdcem horního posuvníku 
směrem doleva tak dlouho, než bílé plo-
chy textu zmizí. 

Bílé plochy zmizí a zůstane jen okousaný text. 
Tento způsob práce s maskou vám umožní kdy-
koli změnit jak text, tak i způsob poškození.

Text pokrytý vzorkem
Další šikovné využití stylů vrstev je možnost pokrýt objekt 
nějakým vzorkem. Pokud je tímto objektem text, můžete 
s ním donekonečna kouzlit, aniž byste přišli o možnost 
kdykoliv jej změnit (obsah textu, jeho velikost, font…).

1. Vytvořte nový dokument 500 × 150 pixelů.
2. Dříve než napíšeme nějaký text, si vytvoříme vzo-

rek, kterým později text pokryjeme. Vzorek není 
potřeba hned kreslit, stačí si vybrat nějaký z před-
nastavených tvarů například v paletce Tvar (Shape), 
která se zpřístupní na panelu nástrojů u nástroje 
Jiné tvary (Custom Shape Tool). 

3. V pravém rohu paletky zmáčkněte tlačítko s šip-
kou a z kontextového menu vyberte příkaz Načíst 
tvary (Load Shapes). Ze seznamu vyberte soubor 
Nature.csh a potvrďte OK. Do paletky se tak při-
hrají přírodní tvary, ze kterých vybereme napří-
klad čtyřlístek.

4. Nastavte barvu popředí na tmavě zelenou 
#497d00.
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Obrázek 5.28 Nastavení prolnutí

Obrázek 5.29 Poškozený text

Obrázek 5.30 Paletka tvarů

Obrázek 5.31 Nástroj Tvary (Shape 
Tool)
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5. Kurzor myši stiskněte někde nad dokumentem a tažením myší 
nakreslete čtyřlístek asi 30 × 30 pixelů (jeho velikost můžete 
během kreslení sledovat na paletce Info). Po uvolnění myši se čtyř-
lístek vyplní zelenou barvou popředí.

6. Zvolte výběrový nástroj (Rectangular Marquee Tool) a kolem čtyř-
lístku nakreslete čtvercový výběr. 

7. Zvolte příkaz Úpravy → Defi novat vzorek (Edit → Defi ne Pat-
tern) a v otevřeném dialogovém okně stiskněte OK. Vzorek je 
hotov a uložen mezi ostatní vzorky.

8. Nástrojem Písmo (Type Tool) napište do dokumentu nějaký text. 
Já jsem zvolil ten nejširší font, jaký jsem měl k dispozici (Baby Kruff y), velikosti 100px. 
Na barvě písma nezáleží, protože jej stejně pokryjeme vzorkem.

9. K vrstvě s textem přidejte styl vrstvy Vrstva → Styl vrstvy → Překrýt vzorkem (Layer 
→ Layer Style → Pattern Overlay). Zde klepněte na náhled vzorku a z náhledů vyberte 
svůj čtyřlístek. Text se pokryje čtyřlístky. 

Pokud se vám nehodí velikost vzorku, můžete ji 
zvětšit, nebo zmenšit změnou nastavení měřít-
ka Scale.

10. Největší výhoda stylů ale je, že je můžete 
navzájem kombinovat. Klepněte v paletce 
stylů vrstev (Layer Style) na styl Překrýt 
přechodem (Gradient Overlay). Původní 
vzorek se překryje přechodem, ale jen do 
té doby, než u přechodu změníme prů-
hlednost krytí na 30 %. Přechod se stane 
průhledným a při nastavení tmavá-světlá-
tmavá se nám písmo na horním a dolním 
konci pěkně ztmaví.

11. K tomu všemu přidejte ještě styl Úkos 
a reliéf (Bevel and Emboss), stačí v základ-
ním nastavení, a Vržený stín (Drop Sha-
dow), a práce je hotová doslova na několik 
klepnutí. 
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Obrázek 5.32 
Výběr kolem 
čtyřlístku

Obrázek 5.33 Zvolte vzorek se čtyřlístkem

Obrázek 5.34 Nastavte barevný přechod

Obrázek 5.35 Výsledný styl se vzorkem
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Text ve stylu šedesátých let
V šedesátých letech minulého století se rozhodně na chrómu nešetřilo. Ať to bylo na autech, 
nebo jiných strojích, nábytku, stavebnictví. Mnohdy i reklamní poutače připomínaly naleště-
nou soustavu trubek. My si vyzkoušíme vyrobit poutač, který bude připomínat čelní masku 
nějakého amerického auta.

1. Vytvořte nový dokument 800 × 300 pixelů.
2. Zvolte nástroj Písmo (Type Tool) a napište do dokumentu text. Já jsem použil font Times 

New Roman Bold velikosti 100 pt. Na barvě textu, ani všech následujících vrstev nezá-
leží, protože je stejně budeme upravovat pomocí stylů vrstev. Text změňte na bitmapu 
příkazem Vrstva → Rastrovat → Písmo (Layer → Rasterize → Type).

3. V samostatném dokumentu si nejprve připravíme 
mřížku, pomocí které text rozložíme na vodorov-
né části. Vytvořte nový dokument 20 × 20 pixelů. 
V něm vytvořte novou vrstvu příkazem Vrstva → 
Nová → Vrstva (Layer → New → Layer) a výbě-
rovým nástrojem (Rectangular Marquee Tool) 
proveďte obdélníkový výběr, který bude velký 20 
× 10 pixelů a bude začínat v levém horním rohu. 
Výběr vyplňte černou barvou. Skryjte základní 
vrstvu a zvolte příkaz Úpravy → Defi novat vzorek (Edit → Defi ne Pattern). V dialo-
govém okně nic neměňte a stiskněte OK. Tím jste si vytvořili vzorek, který použijeme 
pro pokrytí dokumentu pravidelnými proužky. Dokument se vzorkem můžete zavřít 
a vrátit se k původnímu textu.

4. Nad vrstvou s textem vytvořte novou vrstvu a zvolte příkaz Úpravy → Vyplnit (Edit → 
Fill). V dialogovém okně zvolte Použít (Use): Vzorek (Pattern) a z rozbalovací nabídky 
Custom Pattern vyberte svůj nový vzorek, který se přidal na konec seznamu. Potvrďte 
volbu OK. Nová prázdná vrstva se pokryje pravidelnými proužky.

5. Protože jsem zvolil text vysoký 100 pt, přizpůsobil jsem si i velikost vzorku, která se po 
každých 20 pixelech opakuje a tak pokryje beze zbytku celý text. Pomocí nástroje pro 
pohyb (Move Tool) pouze proužky zarovnejte s dolním okrajem textu.

6. Nad vrstvou s textem vytvořte novou prázdnou vrstvu. Do ní vytvoříme chromované 
trubky, ale nebudeme předbíhat. Nejprve je potřeba vytvořit výběr. S přidrženou kláve-
sou Ctrl klepněte na náhled 
vrstvy s textem. Pak klepněte 
na vrstvu s pruhy se součas-
ně přidrženými klávesami 
Ctrl a Alt. Tím od sebe 
výběry odečtete a zbude jen 
přerušovaný text.

7. Výběr dále upravíme takto. 
Výběr → Změnit → Rozšířit 
(Select → Modify → Expand) 
nastavený na 2 pixely pro zvět-
šení výběru na všechny strany. 
Výběr → Změnit → Vyhladit 
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Obrázek 5.36 Vzorek (Pattern)

Obrázek 5.37 Upravený výběr
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(Select → Modify → Smooth) nastavený na 4 pixely, pro zakulacení rohů a pak znovu 
Rozšířit (Expand) nastavený na 1 pixel. Výsledný výběr bude větší než původní písmo 
a bude mít zakulacené rohy. 

8. Pokud nemáte, tak označte jako aktivní 
prázdnou vrstvu a výběr vyplňte barvou. 
Výběr zrušte.

9. Podobným způsobem rozřežeme i vrstvu 
s textem. Opět proveďte výběr vrstvy s tex-
tem a odečtěte od ní výběr vrstvy s pruhy. 
Aniž bychom ale výběr dále upravovali, 
vyberte vrstvu s textem a stiskněte klávesu 
Delete. Obsah výběru se vymaže a z textu 
zbudou jen proužky, ale v opačném pořadí než u vrstvy 
nad ní. Výběr zrušte a zrušte zobrazení vrstvy s pruhy, už 
ji nebudeme potřebovat.

10. Text je nyní připraven na poslední úpravy, které provede-
me pomocí stylu vrstev. Obě vrstvy s textem nyní obsa-
hují rozřezané části textu. Vyberte horní vrstvu a zvolte 
příkaz Vrstva → Styl vrstvy → Překrytí barvou (Layer 
→ Layer Style → Color Overlay). Tímto stylem přebarví-
me doposud jednobarevný text. Potřebujeme chromový 
vzhled a tak použijeme šedomodrou # 828388. Přidáme 
zvlnění stylem Satén (Satin) nastaveným podle obráz-
ku. Je důležité vybrat z nabídky Profi l (Contur): křivku 
pojmenovanou Gaussian. Nakonec přidáme plastický 
vzhled Úkos a reliéf (Bevel and Emboss) nastavený pod-
le obrázku. Opět pozor na křivkuProfi l lesku (Gloss 
Contour), která se jmenuje Rolling Slope – Descending. 
Nakonec přidáme vržený stín nastavený na Vzdálenost 
(Distance): 3 a Velikost (Size): 5. Ostatní hodnoty nechte 
v původním nastavení.

11. Označte jako aktivní spodní vrstvu s rozřezaným textem. 
Vrstvě přidáme stejný, jen trochu upravený, styl, jako 
předchozímu textu. Klepněte pravým tlačítkem myši na 
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Obrázek 5.38 Satén (Satin)

Obrázek 5.39 Úkos a reliéf (Bevel and 
Emboss)

Obrázek 5.40 Rozložení 
vrstev a stylů
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vrstvu se stylem a z kontextového menu vyberte příkaz Kopírovat styl vrstvy (Copy 
Layer Style). Pak klepněte na spodní vrstvu s textem a z kontextového menu vyberte 
Vložit styl vrstvy (Paste Layer style). Text ve vrstvě se změní stejným stylem, jaký jste 
před chvílí vytvořili u předchozí vrstvy. Jedinou věc, kterou je potřeba změnit, je barva 
Překrytí barvou (Color Overlay), kterou nastavíte na šedomodrou #336699, aby se od 
sebe vrstvy barevně rozlišily. 

Výsledkem je text složený střídavě z chromovaných a modrých částí. Při použití jiné velikosti 
fontu je potřeba přiměřeně přizpůsobit pruhy, kterými jsme text rozřezali a také styly vrstev.

Text v podobě sušenek
Nedávno mě pobavil pohled na text, který vypadal jako mé oblíbené sušenky. Jsou to koláčky 
(cookies) s kousky čokolády. Ukážeme si, jak podobný text vyrobit.

1. Vytvořte nový dokument 800 × 300 pixelů.
2. Text, který jsem v ukázce použil, se jmenuje Baby Kruff y o velikosti 150 pt, ale stejně tak 

se hodí každý hodně tučný text. Vrstvu s textem změňte na bitmapu příkazem Vrstva → 
Rastrovat → Písmo (Layer → Rasterize → Type).

3. Sušenky jsou kulaté placičky, které se k okrajům zaoblují. Přizpůsobíme proto písmo tak, 
aby nemělo nikde ostré rohy a více se tak podobalo sušenkám. Proveďte výběr vrstvy s pís-
mem nastaveným na 8 pixelů Výběr → Načíst výběr (Select → Load Selection) a zaoblete 
jej Výběr → Změnit → Vyhladit (Select → Modify → Smooth). Výběr vyplňte barvou 
(opět nezáleží na odstínu), převraťte příkazem Výběr → Doplněk (Select → Inverse), a vše, 
co je uvnitř výběru, vymažte klávesou Delete. Tím jsme se zbavili ostrých rohů.

4. Takto připravený text upravíme pomocí stylů vrstev. Nejprve jej pokryjeme texturou, 
aby vypadal zdrsněně, stylem Překrytí vzorkem (Pattern Overlay). Z nabídky vzorků 
(Pattern) vyberte Stone, který je dost jemný a vytvoří texturu sušenky. V druhém kroku 
přebarvíme vrstvu Překrytí barvou (Color Overlay) na oranžovou # ff 7200. Současně 
změňte interakci Styl (Blend Mode) na Color Burn. Text se změní z původní šedé barvy 
vzorku na hnědě oranžovou texturu. Zaoblení vytvoříme stylem Úkos a reliéf (Bevel 
and Emboss) – Vnitřní úkos (Inner Bevel). Změňte hodnoty Velikost (Size): 15, Změkčit 
(Soft en): 6. Ve spodní části okna změňte barvu u Režim (Highlight Mode) na oranžo-
vou # dd8c4d. Sušenka neodráží moc světla, jako například kovové předměty, a změnou 
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Obrázek 5.41 Výsledný text
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Kapitola 5 – Kouzla s textem186

barvy omezíme vliv světlých míst v zaoblení. Nakonec ztmavíme okraje stylem Vnitřní 
záře (Inner Glow). Jeho barvu nastavte na tmavě hnědou # 321b08 a Velikost (Size): 10. 
Výsledný styl můžete doplnit ještě vhodně vrženým stínem, aby byl dojem plastičnosti 
dokonalý.

Písmo ve stylu sušenek je hotové. Jako třešničku na dort si na 
sušenky přidáme kousky čokolády. Pro ně si vytvoříme vlast-
ní texturu v odděleném dokumentu:

1. Vytvořte nový dokument 200 × 200 pixelů a zvolte 
nástroj pro elipsový výběr Elliptical Marquee Tool. 
Tímto nástrojem můžete kreslit kruhové, nebo elipso-
vé výběry. Do nového dokumentu nakreslete postupně 
s přidrženou klávesou Shift několik nepravidelných 
kruhových výběrů. Vytvořte novou vrstvu a výběry 
vyplňte barvou. Výběr zrušte. Nyní si z koleček vytvo-
říme vzorek, který na sebe bude při opakování nava-
zovat. Zvolte příkaz Filtr → Jiné → Posun (Filter → 
Other → Off set) a nastavte jej podle obrázku. 

2. Vypněte zobrazení základní bílé 
vrstvy, vyberte celý dokument Výběr 
→ Vybrat vše (Select → All) a zvol-
te příkaz Úpravy → Defi novat vzo-
rek (Edit → Defi ne Pattern). Tím si 
vytvořený vzorek uložíte k dalšímu 
použití. Dokument můžete zavřít, 
už jej nebudeme potřebovat.

3. Nad vrstvou s textem v původním 
dokumentu vytvořte novou, prázd-
nou, vrstvu a zvolte příkaz Úpravy 
→ Vyplnit (Edit → Fill). V dialogo-
vém okně vyberte z nabídky vzorků 
(Custom Patterns) poslední vzorek, 
měly by to být naše tečky, a potvrďte OK. Vrstva se celá pravidelně vyplní vzorkem.

Vzorek je ale stále příliš pravidelný a tak jej trochu natočíme a posuneme, aby bylo co nejvíce 
kousků čokolády na písmenech a jeho rozložení bylo náhodnější. Zvolte příkaz Úpravy → Libo-
volná transformace (Edit → Free Transform) a natočte celou vrstvu asi o 15°, buď pohybováním 
rohového transformačního bodu, nebo nastavením hodnoty na horním panelu nástrojů.

4. Nyní musíme odstranit tečky tam, kde není písmo, aby byly kousky čokolády, jen na 
sušenkách a ne jinde. Proveďte výběr z vrstvy s textem, výběr převraťte příkazem Výběr 
→ Doplněk (Select → Inverse). Označte vrstvu s tečkami a vše, co je uvnitř výběru, 
smažte klávesou Delete. Výběr zrušte. Tečky jsou již pouze na písmenech.

5. Vzhled teček vylepšíme pomocí stylů vrstvy. Nejprve tečky obarvíme Překrytí barvou 
(Color Overlay) tmavě hnědou barvou # 2b1c0f. Tečky, jako kousky čokolády by také 
měly plasticky vystupovat. Toho opět docílíme stylem vrstvy Úkos a reliéf (Bevel and 
Emboss), ale tentokrát Pillow Emboss, který vytvoří kolem koleček malé prohloubení, 
takže to vypadá, jako když kousky čokolády opravdu vystupují ze sušenky. Vlastnosti 

Obrázek 5.42 Kousky čokolády

Obrázek 5.43 Vytvoření navazování textury
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187Text s vypálenými okraji

stylu nastavte na Velikost (Size): 6, Změkčit (Soft en): 3. To, jak vysoko a strmě budou 
kousky vystupovat nad povrch, ovlivníte i nastavením Úhel (Angle): 130° a Výška 
(Altitude): 58° ve spodní části okna. Nakonec přidáme velmi malý, nevýrazný, stín 
Vržený stín (Drop Shadow) nastavený na Vzdálenost (Distance): 2, Velikost (Size): 4.

Sušenky (písmena) vypadají, jako byste je právě vybalili z krabičky, jen se zakousnout. 

Text s vypálenými okraji
Následující příklad vytvoří písmo, které je tvořeno okraji, které jsou jakoby vypálené do pozadí. 
Procvičíme si zde práci s efekty ve Filter Gallery.

1. Vytvořte nový dokument 600 × 200 pixelů. Zvolte nějaký tučný font a napište text, který 
chcete upravit.

2. Text změňte na bitmapu příkazem Vrstva → Rastrovat → Písmo (Layer → Rasterize → 
Type).

3. Aby tato úprava textu správně fungovala, musíme spojit text buď se základní vrstvou, 
nebo s jinou barevnou plochou, která je pod textem. Nám postačí první možnost a tak 
zvolte příkaz Vrstva → Sloučit vrstvy (Layer → Merge Down).

4. Všechny následující úpravy nyní provedeme pomocí několika efektů z Filter → Filter 
Gallery.

5. Jako první použijte fi ltr Umělecký → Barevné pastelky (Artistic → Colored Pencil) 
s nastavenými parametry Tloušťka pastelky (Pencil Width): 6, Přítlak tahu (Stroke 
Pressure): 10, Jas papíru (Paper Brightness): 28. Z původního textu zbudou jen okraje, 
navíc jakoby šikmo šrafované.

6. V pravé spodní části okna s efekty klepněte na ikonku New Eff ect Layer. V seznamu 
efektů nad ikonkou přibude další řádka s efektem Barevné pastelky (Colored Pencil). 
Změňte efekt na Deformace → Sklo (Distort → Glass) s nastavenými parametry Zkres-
lení (Distortion): 1, Vyhlazení (Smoothness): 3, Textura (Texture): Plátno (Canvas). 
Filtr se změní u nové řádky, ale původní vrstva s efektem Barevné pastelky (Colored 
Pencil) zůstane nezměněná. Oba efekty se tak navzájem překrývají a doplňují. Původní 
rovné okraje se fi ltrem zdeformují, jako byste na ně koukali přes skleněnou tabuli.

Obrázek 5.44 Výsledný sušenkový text
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7. Vytvořte další řádku a fi ltr v ní změňte na fi ltr Tahy štětce → Postřik (Brush Strokes 
→ Spatter) nastavený na Poloměr trysky (Spray Radius): 1, Vyhlazení (Smoothness): 2. 
Okraje se fi ltrem po obvodech roztřepou.

8. Přidejte další, již poslední, vrstvu a efekt změňte na styl Skica → Fotokopie (Sketch → 
Photocopy) nastavený na Detail (Detail): 3, Tmavost (Darkness): 10. Tento fi ltr vyčistí 
text a vyhladí drobné zoubky po okrajích textu. 

Filtry ve Filter Gallery můžete tímto způsobem pomocí 
vrstev kombinovat a zkoušet si jejich vzájemné působení 
dřív, než necháte fi ltry vykreslit do obrázku. 

Text poleptaný kyselinou
Pěkný efekt získáte, když přidáte na text cákance 
nějakého pěkně zeleného slizu.

1. Vytvořte nový dokument 800 × 200 pixe-
lů a vepište do něj text nějakým tučným 
fontem velikým 150 pt.

2. Proveďte výběr z vrstvy s textem Výběr 
→ Načíst výběr (Select → Load Selection) 
a ten zmenšete Výběr → Změnit → Zúžit 
(Select → Modify → Contract) o 4 pixely.

3. Přidejte novou, prázdnou, vrstvu a výběr 
vyplňte barvou. Výběr zrušte. Vznikla 
tak vrstva se zmenšeným textem. Vrstvu 
upravíme fi ltrem Deformace → Zvlnění 
(Filter → Distort → Ripple) nastaveným 
na Stupeň (Amount): 600, Velikost (Size): 
Střední (Medium). Text se rozvlní do 
všech stran.

Kapitola 5 – Kouzla s textem188

Obrázek 5.45 Vypálené okraje

Obrázek 5.46 Vrstvy s fi ltry 
v Galerii fi ltrů (Filter Gallery)

Obrázek 5.47 Text rozvlněný fi ltrem Riple
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4. Rozvlněnou vrstvu obarvíme na zeleno stylem vrstvy Překrytí barvou (Color Overlay) 
#42ff 00 (tato barva vypadá dobře na monitoru, ale pozor, při tisku nebude ani zdaleka 
tak výrazná). Plastického vzhledu docílíte stylem Úkos a reliéf (Bevel and Emboss) nasta-
veným na Vnitřní úkos (Inner Bevel), Velikost (Size): 6, Změkčit (Soft en): 3. Původní 
černý text se pokryl zelenými cákanci.

5. Cákance zasahují i mimo text, a tak je ořežeme, aby byly pouze na písmenech. Proveďte 
opět výběr z textové vrstvy a výběr převraťte Výběr → Doplněk (Select → Inverse). 
V paletce Vrstvy (Layers) vyberte zelenou vrstvu a stiskněte klávesu Delete. Tím odstra-
níte vše, co je mimo text. Výběr zrušte.

6. Celkový vzhled textu můžete ještě vylepšit přidáním plastičnosti původního textu 
a vrženého stínu. 

Text připomínající Ementál
V následující ukázce si vyrobíme plastický text, který bude svými otvory připomínat sýr Ementál.

1. Vytvořte nový dokument 800 × 400 pixelů a vepište do něj text nějakým tučným fontem 
vysokým 300 pt. Text převeďte na bitmapu Vrstva → Rastrovat → Písmo (Layer → 
Rasterize → Type).

2. Dříve, než začneme upravovat text, si musíme připravit vzorek, kterým text proděravíme. 
Vytvořte nový dokument 200 × 200 pixelů a v něm novou vrstvu. Nástrojem pro výběr 
kruhové oblasti nakreslete do dokumentu elipsovitý výběr.

3. S přidrženou klávesou Shift postupně kreslete další výběry, až jich bude alespoň dvacet. 
Výběr zinvertujte Výběr → Doplněk (Select → Invert) a vyplňte žlutou barvou #ff f091.

4. Díry jsou ale příliš pravidelné. Výběr zrušte a zvolte fi ltr Deformace → Vlna (Filter 
→ Distort → Wave). Ten nastavte podle obrázku, aby se tvary děr lehce zdeformovaly 
a vypadaly přirozeně. 

5. Ze vzorku uděláme opakující se texturu fi ltrem Jiné → Posun (Filter → Other → Off set), 
nastaveným na polovinu šířky stran dokumentu vodorovně (Horizontal) +100 a svisle 
(Vertical) +100.

6. Skryjte v dokumentu základní vrstvu, celý dokument vyberte Výběr → Vybrat vše 
(Select → All) a přidejte do vzorků Úpravy → Defi novat vzorek (Edit → Defi ne Pat-
tern). Dokument se vzorkem můžete zavřít, už jej nebudeme potřebovat

Text připomínající Ementál 189

Obrázek 5.48 Cákance kyseliny
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7. Vraťte se k dokumentu s textem. Proveďte výběr vrstvy 
s textem Výběr → Načíst výběr (Select → Load Sele-
ction) a vrstvu skryjte. Vytvořte novou vrstvu a výběr 
vyplňte vzorkem, příkazem Úpravy → Vyplnit (Edit 
→ Fill). Ze seznamu Custom Pattern vyberte vzorek, 
který jste si vytvořili. Výběr zrušte. Tím jsme dokon-
čili první vrstvu textu. Text ale bude lépe vypadat jako 
celý blok sýru. Vytvoříme tedy 3D-text.

8. Vytvořte kopii vrstvy s děravým textem, posuňte ji 
v paletce Vrstvy (Layers) o jednu pozici pod původní 
text, proveďte výběr vrstvy a ten vyplňte tmavě žlu-
tou barvou # ff cc33. Zvolte nástroj pro pohyb (Move 
Tool) a vrstvu posuňte pomocí kurzorových šipek 
o jeden pixel dolů a doprava.

9. Vytvořte kopii posunuté vrstvy a znovu ji posuňte 
o jeden pixel dolů a doprava. Postupně takto vytvoř-
te pět posunutých vrstev. Text tím získá hloubku. 
Označte v paletce Vrstvy (Layers) všechny posunuté 
vrstvy a slučte je do jedné příkazem Vrstva → Slou-
čit vrstvy (Layer → Marge Layers). 

10. Pro ještě větší prohloubení textu vytvořte kopii prá-
vě sloučené vrstvy a ty opět posuňte o pět pixelů dolů 
a doprava. Takto můžete text postupně prohloubit 
třeba o 20 pixelů. Kopie vrstev nakonec opět slučte 

Kapitola 5 – Kouzla s textem190

Obrázek 5.50 Posunuté vrstvy 
před sloučením

Obrázek 5.49 Díry do sýru
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do jedné. Pro zlepšení dojmu z hloubky textu přidejte sloučené vrstvě styl vrstvy Vnitř-
ní stín (Inner Shadow) barvy #cc9933 nastavený na Vzdálenost (Distance): 7, Velikost 
(Size): 16.

11. Původní vrstva s děravým textem nám nyní částečně zakrývá 3D-část textu. Posuňte 
tedy text o tolik pixelů, o kolik jste text prohloubili směrem dolů a doprava.

Text je hotový. Podle chuti jej můžete doplnit dalšími styly vrstev, například vrženým stínem 
(Drop Shadow). 

Digitální čas
Ukážeme si, jak upravit text (nebo černobílou grafi ku) tak, aby vypadal, jako zobrazený na dis-
pleji telefonu, nebo jiného digitálního zařízení.

1. Vytvořte nový dokument 800 × 400. Doprostřed vepište text nějakým tučným fontem 
velikosti 200 pt. Font převeďte na bitmapu Vrstva → Rastrovat → Písmo (Layer → 
Rasterize → Type).

2. Základem displeje jsou malé čtverečky, které jsou buď aktivní (černé), nebo neaktivní 
(průhledné). Pod nimi je jednobarevné pozadí. Pro čtverečky si vytvoříme v odděleném 
dokumentu vlastní rastr.

3. Vytvořte nový dokument 10 × 10 pixelů. Velikost doku-
mentu závisí na tom, jak velké čtverečky potřebujete 
vytvořit. Náš text je vysoký 200 pt, takže při velikosti 
rastru 10 px bude složen z 20 čtverečků na výšku.

4. Zvolte nástroj pro obdélníkový výběr (Rectangular 
Marquee Tool) a nakreslete po levé straně dokumen-
tu obdélník široký 2 pixely. Přidržte klávesu Shift 
a nakreslete v horní části dokumentu obdélník vysoký 
2 pixely. Vytvořte v dokumentu novou vrstvu a výběr 
vyplňte bílou barvou. Skryjte základní vrstvu doku-

Digitální čas 191

Obrázek 5.51 Hotový text

Obrázek 5.52 Vzorek rastru
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mentu, proveďte výběr celého dokumentu Výběr → Vybrat vše (Select → All) a změňte 
jej na vzorek Úpravy → Defi novat vzorek (Edit → Defi ne Pattern).

5. Vraťte se do dokumentu s textem, vytvořte novou vrstvu a vyplňte ji vzorkem, příkazem 
Úpravy → Vyplnit (Edit → Fill). Ze seznamu vzorků musíte vybrat vámi vytvořený rastr 
(najdete jej na konci seznamu). Dokument se pokryje bílou mřížkou.

6. V tuto chvíli máte možnost posunout text v dokumentu tak, aby byl zarovnaný k horní 
části mřížky a písmena nebyla někde ořezaná.

7. Označte vrstvu s textem a upravte ji fi ltrem Seskupení → Mozaika (Filter → Pixelate → 
Mosaic) nastaveným na Strana (Cell Size): 10 pixelů. Pozor, hodnota musí být stejná jako 
je velikost rastru mřížky. Okraje textu se změní na čtverečky, takže už text nepřesahuje 
okraje rastru.

8. Takto zubatý text nyní rozřežeme podle mřížky. Proveďte výběr z vrstvy s mřížkou, 
označte vrstvu s textem a stiskněte klávesu Delete. Text se rozloží na čtverečky. Výběr 
zrušte a vrstvu s textem slučte se základní vrstvou Vrstva → Sloučit vrstvy (Layer → 
Merge Down).

9. Některé krajní pixely jsou ale šedé. To napravíme úpravou úrovní Obraz → Přizpůsobit 
→ Úrovně (Image → Adjustments → Levels) nastavených na 107, 1, 109.

10. Text už je dostatečně čtverečkovaný, stačí přidat oranžové pozadí displeje. Proveďte výběr 
textu v základní vrstvě příkazem Výběr → Rozsah barev (Select → Color Range). V nabíd-
ce Vybrat (Select) vyberte Stíny (Shadows). Obsah výběru pak zkopírujte do nové vrstvy 
příkazem Vrstva → Nová → Vrstva kopírováním (Layer → New → Layer Via Copy).

11. Označte základní vrstvu a vyplňte ji oranžovou barvou #ff a54d. Černý text teď pěkně 
vyniká na výrazném pozadí.

12. Vytvořte mezi základní vrstvou a textem ještě jednu, novou, vrstvu. Proveďte výběr vrst-
vy s mřížkou, výběr zinvertujte a vyplňte černou barvou. Tím se sice text ztratí pod 
černými čtverečky, ale jen do doby, než změníte průhlednost vrstvy na Krytí (Opacity): 
10 %. Přes celý displej se pak vytvoří čtverečky o trochu tmavší než pozadí displeje. 

Ze stejného displeje můžeme několika jednoduchými úpravami vytvořit displej podsvětlený. 
Ten bude mít v praxi opačné barvy. Pozadí bude tmavé a písmena světlá. Kolem písmen ale 
přibude prosvětlení.

1. Změňte barvu pozadí na tmavě modrou #003264.

Kapitola 5 – Kouzla s textem192

Obrázek 5.53 Digitální displej

K1315.indd   192K1315.indd   192 23.10.2008   11:14:2023.10.2008   11:14:20



2. Označte vrstvu se čtverečky a pomocí stylu vrstvy Překrytí přechodem (Color Overlay) 
změňte barvu čtverečků na modrou #25399c.

3. Nakonec změňte stejným způsobem barvu textu na světle modrou #28c8ff . Textu navíc 
přidejte styl vrstvy Vnější záře (Outer Glow) stejné barvy a Velikosti (Size): 12 pixelů. 
Kolem textu se tak vytvoří záře, jako by text osvětloval okolní buňky displeje. 

Technický text
Většina příkladů na úpravu textu pracuje nejlépe s tučnými fonty. Pro následující příklad si ale 
vyberte nějaký méně tučný, nejlépe patkový, font.

1. Vytvořte nový dokument 800 × 400 pixelů. Fontem Times New Roman vysokým 180 pt 
vepište do dokumentu text. Text změňte na grafi ku příkazem Vrstva → Rastrovat → 
Písmo (Layer → Rasterize → Type).

2. Příkazem Výběr → Načíst výběr (Select → Load Selectin) vyberte černou barvu textu 
a výběr zmenšete příkazem Výběr → Změnit → Zúžit (Select → Modify → Contract) 
o 3 pixely. Obsah výběru smažte klávesou Delete. Z textu zbudou pouze obrysy.

3. Vytvořte dvě kopie vrstvy s textem. Označte jako aktivní první vrstvu (tu, co je nejníže 
v paletce Vrstvy) a rozostřete ji fi ltrem Rozostřit → Rozmáznout (Filter → Blur → 
Motion Blur) nastaveným na Úhel (Angle): 0°, Vzdálenost (Distance): 160. Text se rozos-
tří ve vodorovném směru.

4. Označte jako aktivní druhou vrstvu s textem (v paletce Vrstvy o jednu výš) a rozostřete 
ji fi ltrem Rozostřit → Rozmáznout (Filter → Blur → Motion Blur) nastaveným na Úhel 
(An gle): 90°, Vzdálenost (Distance): 160. Text se rozostří ve svislém směru.

5. Na pozadí textu se vykreslily vodorovné a svislé pruhy v místech, kde jsou písmena. Díky 
tomu, že jsme odstranili vnitřky písmen, můžeme skrz písmena vidět rozmazané pozadí. 
Nezbývá než zvýraznit text v popředí.

6. Ten zvýrazníme pomocí stylů vrstev. Vyberte v paletce Vrstvy (Layers) vrstvu nejvíc 
nahoře. Nejprve podle potřeby upravíme barvu textu stylem Vrstva → Styl vrstvy, Pře-
krytí barvou (Layer → Layer Style → Color Overlay). Já zvolil modrou # 336699. Přidá-
me ne příliš výrazný stín Vzdálenost (Distance): 10, Velikost (Size): 8.

Obrázek 5.54 Prosvětlený digitální displej
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7. Nakonec textu přidáme kovový lesk stylem Úkos a reliéf (Bevel and Emboss) nastave-
ným podle obrázku. Nezapomeňte ve spodní části okna změnit křivku z Linear na Ring 
– Double. 

Kapitola 5 – Kouzla s textem194

Obrázek 5.56 Technický text

Obrázek 5.55 Změna nastavení křivky
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Okousaný text
Následující úprava textu je tvořena styly vrstev s využitím masky, která vytvoří dojem, že je 
z písmen okousána horní vrstva.

1. Vytvořte nový dokument 800 × 260 pixelů. Aby příklad lépe vynikl, změníme barvu poza-
dí na černou a do dokumentu vepíšeme bílý středně tučný text velikosti 180 pt. Text změňte 
na bitmapu příkazem Vrstva → Rastrovat → Písmo (Layer → Rasterize → Type).

2. Proveďte výběr vrstvy s textem a výběr zmenšete Výběr → Změnit → Zúžit (Select → 
Modify → Contract) o 3 pixely. Vytvořte novou, prázdnou vrstvu pod vrstvou s textem 
a výběr vyplňte barvou. Získáme tím zmenšenou kopii textu. Výběr zrušte.

3. Označte jako aktivní původní vrstvu s textem. Vrstvu upravíme pomocí stylů vrstev 
a začneme barvou textu. Ten pokryjeme texturou pomocí stylu Vrstva → Styl vrstvy → 
Překrytí vzorkem (Layer → Layer Style → Pattern Overlay). Abychom si procvičili práci 
s texturou, přidáme do nabídky standardních textur novou sadu. Klepněte na nabídku 
Vzorek (Pattern) a pak na šipku v pravém horním rohu paletky. Z kontextového menu 
vyberte sadu Barevný papír (Color Paper). Sadu nechte připojit k současné sadě Připojit 
(Append). Z nových vzorků, které se přidaly do paletky, vyberte okrový Buff  Textured 
(který připomíná kůži). 

4. Potom zaoblíme okraje textu stylem Úkos a reliéf (Bevel and Emboss) nastaveným na 
Vnitřní úkos (Inner Bevel), Hloubka (Depth): 120 %, Velikost (Size): 6 pixelů.

5. Hloubku textu nakonec zvýrazníme stylem Vnitřní záře (Inner Glow) černé barvy veli-
kosti (Size) 6 pixelů.

6. Stejný styl použijeme i u spodní vrstvy se zmenšeným textem. Klepněte na vrstvu se sty-
lem pravým tlačítkem myši a z kontextového menu vyberte příkaz Kopírovat styl vrstvy 

Okousaný text 195

Obrázek 5.57 Změna textury

K
o

u
zl

a
 

s 
te

x
te

m
5

K1315.indd   195K1315.indd   195 23.10.2008   11:14:2223.10.2008   11:14:22



Kapitola 5 – Kouzla s textem196

(Copy Layer Style). Pak klepněte pravým tlačítkem myši 
na vrstvu se zmenšeným textem a z kontextového menu 
vyberte příkaz Vložit styl vrstvy (Paste Layer Style). 
Vrstva se upraví stejným stylem (který zatím nevidíme, 
protože vrstva je skryta pod horní vrstvou s textem). Ve 
stylu provedeme jednu malou úpravu tím, že změníme 
texturu z Buff  Textured na mnohem světlejší vzorek 
Gold Vellum. 

7. Označte v paletce Vrstvy vrstvu s textem a vytvoř-
te novou masku vrstvy Vrstva → Maska vrstvy → 
Odkrýt vše (Layer → Layer Mask → Reveal All). Na 
první pohled se nic nezmění, jen v paletce Vrstvy při-
bude v textu ná hled masky. Zvolte nástroj Štětec (Brush 
Tool) velikosti 8 pixelů a nastavte mu ostré okraje (Hard-
ness: 100 %). Vše, co nyní do obrázku nakreslíte, ovlivní 
vzhled masky, a tím i horní vrstvy s textem. Klepnutím 
na okraje textu kreslete do masky kolečka, která budou 
představovat stopy po zubech nějakého hlodavce. Maska 
vrstvy bude nakonec složená z malých černých bodů. 

8. Tím, že kreslíte černou barvou, vytváříte vrstvu neprůhlednosti, za kterou se skryje část 
vrstvy s textem. Tím se odhalí vrstva se zmenšeným textem a vytvoří dojem ohlodané 
kosti. 

Přepůlený text
Už jste zkusili, co se stane, když text (nebo jiný objekt) upravený stylem vrstvy překryjete mas-
kou vrstvy? Jestli ano, možná jste byli nepříjemně překvapeni chováním stylu.

1. Vytvořte nový dokument 800 × 400 pixelů, tentokrát s černým pozadím a vepište dopro-
střed bílý text vysoký 360 pt.

2. Použijeme na něj styl vrstvy (v zásadě můžete použít jakýkoliv, ale na tomto stylu 
dobře uvidíte, jak se styly napojují). Nejprve text přebarvěte na šedou (Color Over-
lay) #b4b4b4. Potom přidejte zkosení hran (Bevel and Emboss) Velikost (Size): 5 pixe-
lů. Nakonec uděláme zesvětlení písmen po celém obvodu stylem Vnitřní záře (Inner 

Obrázek 5.59 Na kost

Obrázek 5.58 Styly a maska 
vrstvy
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197Přepůlený text

Glow) nastaveným na Režim (Blend Mode): Normální (Normal), Krytí (Opacity): 
100%, Velikost (Size) 26 pixelů.

3. Zkusíme, co s textem udělá maska vrstvy. Vyberte výběrový nástroj (Rectangle Marquee 
Tool) a nakreslete výběr, který začne v levém horním rohu dokumentu a skončí asi 
v polovině stránky na protější straně. Příkazem Vrstva → Maska vrstvy → Odkrýt 
výběr (Layer → Layer Mask → Reveal Selection) vytvoříte z výběru masku, která skryje 
spodní polovinu textu. Spodní, uříznutá, hrana textu se ale zkosila stejně jako okraje. 
Můj záměr ale bude obě poloviny textu znovu napojit a toto chování stylu se mi nelíbí. 
Klepněte dvakrát na vrstvu s textem a v okně pro nastavení stylů označte volbu Maska 
vrstvy skryje styl (Layer Mask Hides Eff ects). Tím zrušíte působení masky a styl vrstvy 
bude procházet beze změny dál až pod masku. 

4. Vytvořte kopii vrstvy s textem Vrstva → Duplikovat (Layer → Duplicate Layer) a klep-
něte na náhled masky. Pak zvolte příkaz Obraz → Nastavení → Invertovat (Image → 
Adjustments → Invert). Barvy masky se převrátí a odkryje se spodní část masky, takže 
text zase vidíte celý.

5. Kopírováním vrstvy se automaticky zkopíroval i původní styl vrstvy. Ten nyní trochu 
upravíme, aby se poloviny textu od sebe odlišily. Pro názornost bude stačit, když změníte 
přebarvení textu z Překrytí barvou (Color Overlay) na Překrytí přechodem (Gradi-
ent Overlay). Styl přechodu jsem zvolil Zrcadlový (Refl ected), aby se písmo ztmavilo ze 
středu na obě strany, jinak by byl přechod nevýrazný. 

Obrázek 5.60 Zkosená hrana

Obrázek 5.61 Maska vrstvy skryje styl

Obrázek 5.62 Rovná hrana

Obrázek 5.63 Nastavení přebarvení 
přechodem
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6. Obě poloviny textu na 
sebe navazují a přitom 
je každá upravená jiným 
stylem vrstvy, a text je 
stále editovatelný. 

Želé
Že lze pouze za pomoci stylů vrstvy dosáhnout výborných výsledků, už víme. Jeden takový 
příklad si ukážeme. Abychom stále jen neupravovali písmena, zvolil jsem pro tuto ukázku vek-
torový objekt z knihovny přednastavených tvarů.

1. Vytvořte nový dokument 400 × 400 pixelů. Zvolte nástroj Custom Shape Tool a vyberte 
si nějaký tvar z knihovny Tvar (Shape) na horním panelu nástrojů (já jsem si do knihovny 
přidal tvary zvířat (Animals) a z nich vybral zajíčka). Klepněte do levého horního rohu 
dokumentu a tažením do protilehlého rohu nakreslete tvar, který je tvořen vektorovou 
křivkou podobně jako text. Tvar upravíme tak, že bude vypadat jako cukrátko z želé.

2. Zvolte příkaz Vrstva → Styl vrstvy → Přebarvit přechodem (Layer → Layer Mask → 
Gradient Overlay). Přechod nastavte ze světle zelené #b8f00e do tmavě zelené #056600. 
Přechod zvolte Lineární (Linear), ale pootočte jej na 112°, aby šel šikmo přes obrázek.

3. Jako druhý přidejte styl Úkos a reliéf (Bevel and Emboss) nastavený na Vnitřní úkos 
(Inner Bevel) Hloubka (Depth): 200 %. Ve spodní části okna je potřeba změnit křivku 
Gloss Contur. Když klepnete na náhled 
křivky, otevře se okno pro nastavení tva-
ru křivky. My potřebujeme dodat objektu 
plastičnost a tak upravíme křivku tak, aby 
nebyla tak strmá. Stačí, když posunete bod 
z levé spodní části okna směrem nahoru 
přibližně do poloviny. Obrázek se zaoblí 
do poloviny své šířky.

4. Jako třetí přidáme styl Vnitřní stín (Inner 
Shadow). Jeho barvu změňte na tmavě 
zelenou #056600 a nastavte Vzdálenost 
(Distance): 16, Velikost (Size) 10. Levá 
strana obrázku se ztmaví a vytvoří tak 
dojem větší hloubky.

5. Další styl udělá dojem, že je objekt na obráz-
ku průhledný a že je vidět na jeho protější 
stranu. Je to styl Vnitřní záře (Inner Glow). 
Jeho barvu nastavte na hodně světle zele-

Kapitola 5 – Kouzla s textem198

Obrázek 5.64 Přepůlený text

Obrázek 5.65 Nastavení křivky
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nou #befa0c, Vyseknutí Choke: 6 % a Velikost (Size): 9 pixelů. Křivku (Contour) vyberte 
Ring z přednastavených křivek. Kolem obvodu obrázku se vytvoří dvojitá tlustá čára.

6. Aby byl dojem želé dokonalý, přidáme nakonec texturu, která pokryje horní část obráz-
ku. Pod stylem Úkos a Reliéf jsou ještě dva vnořené styly. Druhý z nich Textura (Textu-
re) použijeme. Do seznamu textur přidejte textury Barevný papír (Color Paper) (z kon-
textového menu, které se zobrazí 
po stisknutí ikonky šipky v pra-
vém horním rohu paletky) a z nich 
vyberte White textured. Rozměr 
(Scale) nastavte na 33 % a Hloubku 
(Depth): 18 %. Obrázek se pokryje 
jemnou texturou.

7. Pro zvýraznění obrysů můžete ješ-
tě přidat styl Ohraničení (Strokes). 
U něj nastavte barvu ohraničení 
#066f00 a tloušťku 2 pixely, Umís-
tění (Position): Uprostřed.

Výsledný styl se vám možná může zdát 
trochu složitý, ale výsledek za to stojí. 
Dojem želatinového cukrátka je opravdu 
věrný. 

Želé 199

Obrázek 5.66 Změna textury

Obrázek 5.67 Želé

K
o

u
zl

a
 

s 
te

x
te

m
5

K1315.indd   199K1315.indd   199 23.10.2008   11:14:2423.10.2008   11:14:24



Diamant
Další příklad toho, jak se dají styly vrstev kombinovat, je ukázka skleněného objektu, například 
diamantu.

1. Vytvořte nový dokument 400 × 400 pixelů a nástrojem Custom Shape Tool do něj 
nakreslete kosočtverec (na něm se nejlépe vytvářejí odlesky).

2. Začneme stylem vrstvy Překrytí přechodem (Gradient Overlay). Barevný přechod 
nastavte od bílé do světle modré #38bbff . Styl přechodu zvolte Diamant (Diamond), 
Velikost (Scale): 80 %. Uprostřed kosočtverce se vykreslí bílý kříž, jako odlesk světla.

3. Jako druhý přidejte styl Úkos a reli-
éf – Vnitřní úkos (Inner Bevel) 
nastavený na Hloubka (Depth): 
600, Velikost (Size): 24, Změkčit 
(Soft en): 4. Křivku pro zkosení 
hran nastavte podle obrázku. 

4. U úkosu navíc zvýrazníme Obrys 
(Contour) křivkou s rozsahem 
(Range): 30 %.

5. Hloubku diamantu zvýrazníme 
přidáním Vnitřního stínu (Inner 
Shadow) modré barvy #002270, 
Vzdálenost (Distance): 20, Velikost (Size): 16. Levá 
horní strana se tím ztmaví, jakoby byla zastíněná.

6. Dojem průhlednosti zvýšíme přidáním stylu 
Vnitřní záře (Inner Glow) nastaveným na Krytí 
(Opacity): 70 %, Vyseknutí (Choke): 18 %, Veli-
kost (Size): 24.

7. Nakonec přidáme Vržený stín (Drop Shadow) (ne 
moc výrazný, protože průhledné předměty vytvá-
řejí tlumený stín), barvy #2d7cc0, nastavený na 
Krytí (Opacity): 44 %, Vzdálenost (Distance): 14, 
Velikost (Size): 20.

Cokoli tímto stylem upravíte, bude vypadat jako skleněný 
blok. 

Průhledný text
Jak vyrobit skleněný objekt (diamant) jsme si předvedli v předchozí ukázce, podobný styl si nyní 
převedeme na text a navíc ještě přidáme průhlednost písma, takže bude možné přes text vidět 
pozadí.

1. Základem příkladu bude nějaký obrázek, na kterém budeme demonstrovat průhlednost 
písma. Otevřete některý z ukázkových obrázků (já jsem použil Most_II.tif).

2. Do obrázku vepište text vysoký přibližně 500 pixelů. Skleněný text vypadá lépe, když má 
písmo zaoblené rohy. Na barvě textu nezáleží, protože ji hned upravíme stylem vrstvy.

3. Zvolte styl Vrstva → Styl vrstvy → Překrytí přechodem (Layer → Layer Style → Gradi-
ent Overlay) a přechod nastavte Zrcadlový (Refl ected) od modré #438ecc do tmavě mod-

Kapitola 5 – Kouzla s textem200

Obrázek 5.68 Křivka 
zkosení hran

Obrázek 5.69 Křivka 
obrysu

Obrázek 5.70 Diamant
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ré #0a5aa0, Krytí: 100 %, Úhel (Angle): 90, Velikost (Scale):  
110 %. Písmo se zbarví tmavě modrou a od středu ke krajům 
se bude zesvětlovat.

4. Jako další styl přidejte Úkos a reliéf – Vnitřní úkos (Bevel 
and Emboss – Inner Bevel). Ten nastavte Hloubka (Depth) 
140 %, Velikost (Size): 40, Vyhlazení (Soft en): 10, Úhel (An-
gle): 120/40°. Křivku nastavte esovitě podle obrázku. 

5. Okraje opět ztmavíme stylem Vnitřní záře (Inner Glow) tma-
vomodré barvy #0e2053, nastaveným na Velikost (Size) 30.

6. Nakonec přidáme Vnitřní stín (Inner Shadow) stejné barvy 
jako vnitřní záře, Vzdálenost (Distance): 5, Velikost (Size): 35.

Text vypadá plasticky, a můžete jej, pokud se vám 
líbí, ihned použít, ale moc skleněný zatím není. 

1. Vytvořte kopii vrstvy s obrázkem a posuň-
te ji nad vrstvu s textem. Vyberte příkaz 
Vrstva → Vytvořit ořezovou masku 
(Layer → Create Clipping Mask). Obrázek 
se ořeže podle textu pod obrázkem.

2. Text je ale najednou nebarevný a na pozadí 
téměř zaniká. Barevnost přidáme jednodu-
še. U vrstvy s kopií obrázku snižte v palet-
ce Vrstvy Výplň (Fill) na 66 %. Vrstva už 
nebude tak překrývat text a pod ní začne 
prosvítat modrá barva pásma.

3. Tím se viditelnost písma zlepšila, ale ještě by to něco chtělo. Začneme stylem Vnější záře 
(Outer Glow), kterou používám vždy, když je potřeba zvýraznit okraje na různobarev-
ném pozadí. Režim (Blend Mode) nastavte na Překrýt (Overlay), Krytí (Opacity): 56 %, 
a Velikost (Size): 16.

4. Nakonec přidáme Vržený stín 
(Drop Shadow) Vzdálenost 
(Distance): 10 pixelů, Velikost 
(Size): 12 pixelů.

Text už vypadá jak má. Je plastický, 
průhledný a dostatečně čitelný. 

Aby byl dojem skleněného textu 
dokonalý, měl by být obrázek za 
textem zvětšený, jako za lupou. 
Označte vrstvu s kopií obrázku 
a zvolte Úpravy → Transformovat 
(Edit → Free Transform). Na horním 
panelu nástrojů nastavte zvětše-
ní na 110 % a potvrďte klávesou 
Enter. Obrázek v masce se zvětší, 
takže v textu bude vypadat jako 
odsazený od původního obrázku.

Průhledný text 201

Obrázek 5.71 Křivka 
vnitřního úkosu

Obrázek 5.72 Plastický, neprůhledný, text

Obrázek 5.73 Plastický, průhledný, text
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Zasí�ovaný text
Pěknou úpravu textu jsem nedávno viděl na stránkách Adobe, a tak si můžeme ukázat, jak 
podobného efektu dosáhnout. Text byl tvořen pouze obvodovými čarami, vnitřek písmen byl 
průhledný a vytkaný sítí.

1. Otevřete nový dokument 600 × 400 pixelů. Doprostřed vepište text vysoký 360 pt a pře-
veďte jej na bitmapu.

2. Vytvořte novou vrstvu a tu vyplňte šedou barvou #cccccc. Nastavte barvu popředí (Fore-
ground Color) na černou a zvolte fi ltr Textura → Mozaikové okno (Filter → Texture → 
Stained Glass). Ten nastavte na Velikost plošek (Cell Size): 12 a Tloušťka obrysů (Border 
Tickness): 4, Intenzita světla (Light Intensity): 3. Šedá plocha se rozdělí černými čarami 
na nepravidelnou síť.

3. Zvolte příkaz Výběr → Rozsah barev (Select → Color Range), nastavte Neurčitost (Fuz-
ziness): 10 a vyberte šedou barvu. Výběr vymažte klávesou Delete. Z vrstvy s mřížkou 
zbyla jen černá síť.

4. Proveďte výběr vrstvy s textem, skryjte ji, 
označte vrstvu se sítí a vytvořte u vrstvy 
masku příkazem Vrstva → Maska vrstvy 
→ Odkrýt výběr (Layer → Layer Mask → 
Reveal Selection). Maska skryje okolí textu 
a síť bude vetkaná jen uvnitř textu.

5. Aby síť působila plasticky, upravíme ji 
stylem vrstvy. Začneme ohraničením 
Vytažení (Stroke) nastaveným podle 
obrázku. Síť jsem ohraničil gradientem, 
protože tento druh ohraničení vytvoří 
jemnější linky než pouhé ohraničení bar-
vou.

6. Další styl přidáme Úkos a reliéf – Vnitřní 
úkos (Bevel and Emboss – Inner Bevel) pro 
zvýšení plastičnosti. Hloubku (Depth) nastavte na 250 %, Velikost (Size): 3 pixely, Úhel 
(Angle): 120/60. Křivku nastavte podle obrázku. U úkosu ještě zvýrazníme obrysy Profi l 
(Contour) změnou křivky na Poloviční oblouk (Half Round).

7. Nakonec síť podbarvíme Vrženým stínem (Drop Shadow), Krytí (Opacity): 60 %, Vzdá-
lenost (Distance): 4 pixely, Velikost (Size): 5 pixelů.

8. V obrázku máme nyní síť, vystřiženou obrysem písmen. 
Vytvořte kopii vrstvy s textem a přesuňte ji nad vrstvu se sítí. 
Proveďte výběr vrstvy Výběr → Načíst výběr (Select → Load 
Selection). Výběr zmenšete Výběr → Změnit → Zúžit (Select 
→ Modify → Contract): 5 pixelů a obsah výběru vymažte klá-
vesou Delete. Z textu zbyly jen okraje široké 5 pixelů. Okraje 
upravíme podobným stylem jako síť.

9. Nejprve okraje přebarvíme Vytáhnout (Stroke), Velikost 
(Size): 6 pixelů, (Position): Uvnitř (Inside), Typ výplně (Fill 
Type): Gradient. Přechod gradientu nastavte z tmavě modré # 
002a68 do světle modré # b4e4fa. Jezdec světlé barvy posuňte 

Kapitola 5 – Kouzla s textem202

Obrázek 5.74 Vytažení (Stroke)

Obrázek 5.75 Křivka 
pro Vnitřní úkos (Inner 
Bevel)
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po pravítku směrem doleva na hodnotu Pozice (Location): 46 %. Styl přechodu zvolte 
Shape Burst. Ohraničení textu se po obvodu vyplní tmavším odstínem modré a bude 
vypadat, jako by bylo z něčeho kulatého.

10. Nakonec přidáme styl Vržený stín (Drop Shadow), Vzdálenost (Distance): 6 pixelů, 
Velikost (Size): 7 pixelů, abychom zdůraznili, že je text opravdu průhledný.

11. Komu by vadilo, že stín od sítě přesahuje okraje textu, může jej jednoduše skrýt, když 
klepnete v paletce Vrstvy (Layers) dvakrát na vrstvu se sítí a v otevřeném panelu označí-
te možnost Maska vrstvy 
skryje efekty (Layer Mask 
Hides Eff ects). Styl vrst-
vy se skryje za maskou 
a nebude přesahovat.

Kdo by chtěl vytvořit opravdu 
hustou síť, může ještě jednou 
zopakovat vytvoření vrstvy se 
sítí. U fi ltru Mozaikové okno 
(Stained Glass) jen změňte na-
stavení Velikost buňky (Cell 
Size): 16. Dvě vrstvy se sítí nad se-
bou vytvoří mnohem zajímavější 
efekt. 

Písmo ve stylu Pána prstenů
Pro potěšení příznivců historických fi lmů jsem vám připravil návod, jak upravit text do podoby 
tajemného starověkého písma. Na celkovém dojmu se významně podílí i tvar a uspořádání pís-
men, proto začneme úpravami tvaru a polohy textu a pak teprve jeho vzhledu. Slovo, které budu 
upravovat, jsem si vypůjčil z fi lmu Pán prstenů. Když se rozhodnete pro jiný text, budete muset 
polohu písmen upravit podle vlastních představ.

1. Vytvořte nový dokument 800 × 400 pixelů s černým pozadím. Pro naše účely se hodí 
nějaký ne příliš tučný, patkový, font, takže klidně použijeme Times New Roman, velikos-
ti 300 pt. Doprostřed dokumentu vepište text bílé barvy.

2. Již při psaní textu můžete ovlivnit 
velikost písma. V textu označte všech-
na písmena kromě prvního (INGS) 
a na horním panelu nástrojů změňte 
velikost písmen na 220 pt. Pak vyber-
te pouze druhé písmeno (I) a změňte 
jeho velikost na 200 pt. Text převeďte 
na bitmapu Vrstva → Rastrovat → 
Písmo (Layer → Rasterize → Type).

3. Každé písmeno nyní upravíme zvlášť 
tak, že změníme jeho velikost a polo-

Písmo ve stylu Pána prstenů 203

Obrázek 5.76 Zasíťovaný text

Obrázek 5.77 Rozmístění písmen textu
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hu. Vyberte nástroj Laso (Lasso Tool) 
a nakreslete výběr písmen kromě prv-
ního. Vyberte Nástroj Přesun (Move 
Tool) a pomocí kurzorových šipek na 
klávesnici posuňte text doprostřed 
prvního písmene. Postupně vyberte 
a posuňte všechna písmena blíž k sobě. 

4. První písmeno bývá u těchto nápisů zvý-
razněno protažením některé části písme-
ne. Vy můžete vytáhnout pravou dolní 
nohu. Nástrojem pro obdélníkový výběr 
(Rectangular Marquee Tool) označte 
dolní část nohy, těsně před tím, než se 
začne zahýbat doprava. Zvolte nástroj 
pro pohyb (Move Tool) a vybranou část 
posuňte směrem dolů pod písmeno. 
Nástrojem pro výběr vyberte zbývající 
část nohy, zvolte nástroj Přesun a se stisknutou klávesou Alt posuňte kopii výběru směrem 
doprava dolů tak, aby se noha prodloužila ve směru pohybu. Pak vyberte koncovou část 
nohy, kterou jsme si umístili pod text a připojte ji na konec prodloužené nohy.

Poloha a velikost písmen je hotová, můžeme začít s úpravami vzhledu:
1. Proveďte výběr vrstvy s textem, otevřete paletku Kanály (Channels), vytvořte nový kanál 

Výběr → Uložit výběr jako (Select → Save Selection As) a výběr zrušte. Následující úpravy 
budeme provádět v masce, kterou jsme si připravili do nového kanálu. Zvolte fi ltr Filter 
Gallery.

2. Nejprve vyberte Filtr → Tahy štětce → Postřik (Filter → Brush Strokes → Spatter) 
Poloměr trysky (Spray Radius): 3, Vyhlazení (Smoothness): 5. Okraje písmen se zvlní 
a vykoušou jemnými zoubky.

3. V okně se seznamem použitých fi ltrů klepněte na ikonku Nová vrstva efektu (New eff ect 
layer) a fi ltr změňte na Skica → Otisk (Sketch → Stamp), Vyvážení světel a stínů (Light/
Dark Balance): 1, Vyhlazení (Smoothness): 8. Oba fi ltry na sebe budou působit a zubaté 
okraje se vyhladí, ale zůstane jim původní zvlnění. Parametry fi ltrů můžete libovolně 
měnit a zvýšit, nebo snížit deformaci okrajů písmen.

4. Okraje jsou ještě trochu zubaté 
a tak je vyhladíme fi ltrem Rozost-
řit → Gaussovské rozostření (Blur 
→ Gaussian Blur) 1 pixel. 

5. Proveďte výběr z masky Výběr → 
Načíst výběr (Select → Load Selec-
tion), v paletce Vrstvy (Layers) 
vytvořte novou vrstvu a výběr 
vyplňte bílou barvou. Původní 
vrstvu s textem buď skryjte (ikon-
kou oka), nebo smažte. Už ji nebu-
deme potřebovat.
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Obrázek 5.78 Prodloužení nohy písmene

Obrázek 5.79 Maska s upraveným písmem
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V úpravách vzhledu písmen budeme pokračovat pomocí složeného stylu vrstvy:
1. Nejprve písmena přebarvíme stylem Vrstva → Styl vrstvy → Překrytí barvou (Layer → 

Layer Style → Color Overlay) nastaveným na temně oranžovou # f0c61e.
2. Pokračovat budeme stylem Úkos a reliéf – Reliéf (Bevel and Emboss – Emboss) Hloubka 

(Depth): 120 %, Velikost (Size): 5 pixelů, Úhel/výška (Angle/Altitude): 120/40°. Zkosení 
není příliš vysoké a text je hodně plochý.

3. Hloubku mu přidáme v následujících dvou krocích. Nejprve Vnitřní záře (Inner Glow) 
Barvu změňte na hnědou # 6e5400, Zdroj (Source): Hrana (Edge), Velikost (Size): 12 
pixelů. Kolem každého písmene se vytvoří ztmavení.

4. Nakonec použijte trochu netradičně Vnitřní stín (Inner Shadow) nastavený na Režim 
(Blend Mode), Překrytí (Overlay) bílé barvy, Krytí (Opacity): 80 %, Úhel (Angle): 45°, 
Vzdálenost (Distance): 5 pixelů, Velikost (Size): 3 pixely. Tento stín bude působit svou 
bílou barvou jako světlo, dopadající z levé strany a zvýrazní tak hrany písmen.

Písmena vypadají na historický text až příliš dokonale, 
a tak nabízím malé zlepšení, které přidá textu nepravidelné 
opotřebení:

1. Vytvořte nad vrstvou s textem novou, prázdnou, vrstvu 
a vyplňte ji fi ltrem Filtr → Vykreslit → Oblaka (Filter 
→ Render → Clouds).

2. Vrstva překryje celý dokument napodobením zamrače-
né oblohy. Zvolte příkaz Vrstva → Vytvořit ořezovou 
masku (Layer → Create Clipping Mask), nebo klepně-
te mezi vrstvy s textem a vrstvu s mraky se stisknutou 
klávesou Alt. Mraky by měly zmizet, ale s textem se nic 
nestane.

3. Vraťte se do vrstvy s textem a u stylu Překrytí barvou 
(Color Overlay) změňte Režim (Blend Mode) na Překrýt 
(Overlay). Písmo se ztmaví tam, kde jsou mraky nej-
tmavší a vytvoří se na něm pěkná, nepravidelná, mapa. 

4. Komu se bude zdát mapa moc tmavá, může ji zesvětlit 
pomocí úpravy Úrovní (Levels), nejlépe ve vrstvě úprav, 
abyste mohli zkoušet různá nastavení. Já jsem pouze 
mapu zesvětlil ubrá-
ním jasu posunu-
tím levého dolního 
jezdce na hodnotu 
Výstupní úrovně 
(Output Levels): 
80/255. 

Písmo ve stylu Pána prstenů 205

Obrázek 5.80 Rozložení 
vrstev

Obrázek 5.81 Pán prstenů
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Text v písku
Doposud jsme upravovali nějaký text, ale jeho pozadí zůstávalo nezměněné. Nyní uděláme 
výjimku a upravíme pozadí tak, aby z něj text vystupoval. Jako pozadí si vytvoříme pískovou 
pláž a text bude vypadat, jako když jej do písku vepíšete.

1. Vytvořte nový dokument 800 × 300 pixelů a v něm novou vrstvu.
2. Změňte barvu popředí na tmavě žlutou #ff e6aa a pozadí na světle hnědou #cca558.
3. Vrstvu vyplňte napodobením mraků Filtr → Vykreslit → Oblaka (Filter → Render 

→ Clouds). Vrstva se stane základem pro písečnou pláž. Zrnka písku vytvoříme fi ltrem 
(Filter → Noise → Add Noise) nastaveným na Amount: 6 %, Distribution: Uniform.

4. Doprostřed dokumentu vepište text a proveďte jeho výběr Výběr → Načíst výběr (Select 
→ Load Selection).

5. V paletce Kanály (Channels) vytvořte nový kanál příkazem Výběr → Uložit výběr 
(Select → Save Selection). Výběr zrušte a nový kanál klepnutím vyberte. Další úpravy už 
budeme provádět pouze na masce uložené v kanálu.

6. Nejprve uděláme okraje textu nepravidelně pokroucené fi ltrem Umělecký → Akvarel 
(Filter → Artistic → Watercolor) nastaveným na Detail štětce (Brush Detail): 10, Inten-
zita stínů (Shadow Intensity): 10, Textura (Texture): 1 a Tahy štětce → Nastříkané tahy 
(Brush Strokes → Sprayed Strokes) nastaveným na Délka tahu (Stroke Lenght): 16, Polo-
měr trysky (Spray Radius): 4, Směr tahů (Stroke Direction): Left  Diagonal. Oba fi ltry 
můžete aplikovat současně pomocí Filter Gallery.

7. Masku rozostřete fi ltrem Rozostřit → Gaussovské rozostření (Filter → Blur → Gaus-
sian Blur), Poloměr (Poloměr): 0,6 pixelu a lehce zvlňte fi ltrem Deformace → Vlna → 
(Filter → Distort → Wave) nastaveným podle obrázku. 

8. Nyní si připravíme dokument, který použijeme jako mapu deformace, pro vytlačení 
textu do písku. V paletce Kanály (Channels) klepněte v pravém horním rohu na šipku 
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Obrázek 5.82 Nastavení fi ltru Vlna (Wave)
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v kolečku a z kontextového menu vyberte příkaz Duplikovat kanál (Duplicate Channel) 
a v dialogovém okně příkazu vyberte Dokument → Nový (Document → New). Maska se 
vloží do nového dokumentu, který si uložte například jako já pod jménem alpha_1.psd.

9. V novém dokumentu budeme postupně masku upravovat tak, aby se kolem textu vytvořil 
plynulý přechod z černé do bílé barvy. Nejprve masku zinvertujte Obraz → Přizpůsobit → 
Inverze (Image → Adjustments → Invert), aby byla písmena černá a pozadí bílé. Pak okra-
je rozostřete Filtr → Rozostřit 
→ Gaussovské rozostření (Fil-
ter → Blur → Gaussian Blur), 
Poloměr: 8 pixelů. Filtr ještě 
jednou zopakujte, ale s nasta-
vením Poloměr: 5 a pak ještě 
jednou Poloměr: 2. Přechod 
pak bude směrem k písmenům 
tmavší a maska pak vytvoří 
strmější zaoblení. Dokument 
s maskou uložte. 

10. Vraťte se k dokumentu s pís kem a zvolte fi ltr Textura → Texturování (Filter → Tex-
ture → Texturizer). Tento fi ltr umí přidat obrázku texturu z přednastavených vzorků, 
nebo z vámi vyrobené masky. A to je náš případ. Vpravo od nabídky Textura (Textu-
re) stiskněte tlačítko s šipkou 
a vyberte dokument alpha_
1.psd, který jsme před chvílí 
vytvořili. Obrázek se zdefor-
muje podle odstínů masky. 
Změnou nastavení hodnoty 
Reliéf (Relief) můžete ovlá-
dat hloubku vytlačení masky 
do obrázku. Já jsem nastavil 
hodnotu 40 a Světlo (Light): 
Nahoře vlevo (Top Left ). 

11. Písmena jsou pěkně vytlačená do písku, ale nejsou moc výrazná. Vymažeme střed pís-
men, aby to vypadalo, že pod písmeny něco leží. Proveďte výběr z původního kanálu 
Alpha 1 v paletce Kanály (Channels), označte vrstvu s pískem a stiskněte klávesu Delete. 
Písmena se vymažou a za nimi bude vidět bílá barva pozadí dokumentu.

12. Pod vrstvou s pískem vytvořte novou vrstvu a vyplňte ji hnědou barvou #6c2c01. Za pís-
meny se změní pozadí na hnědou, takže jsou písmena již dobře čitelná.

Textura dřeva
Nyní na chvíli odbočíme od textu a jako pozadí si vytvoříme napodobení textury dřeva, které 
bude jakoby zahrabané do písku z předchozího příkladu. Skryjte všechny vrstvy, kromě vrstvy 
s hnědým pozadím.

1. Upravíme vrstvu, kterou jsme v předchozím cvičení vyplnili hnědou barvou #6c2c01. 
Vrstvu upravte fi ltrem Umělecký → Houba (Filter → Artistic → Sponge) nastaveným 
na Velikost štětce (Brush Size): 10, Vyhraněnost (Defi nition): 16, Vyhlazení (Smoothne-

Textura dřeva 207

Obrázek 5.83 Maska

Obrázek 5.84 Vytlačený reliéf
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ss): 10. Filtr vytvoří na jedno-
barevné ploše světlejší skvrny. 
Filtr ale zopakujte třikrát po 
sobě, aby se vytvořilo víc růz-
nobarevných skvrn.

2. Zvolte nástroj pro pravoúhlý 
výběr (Rectangular Marquee 
Tool) a uprostřed dokumentu 
proveďte obdélníkový výběr na 
celou výšku dokumentu, široký 
přibližně 8 pixelů. Obsah výbě-
ru zkopírujte do nové vrstvy 
příkazem Vrstva → Nová → 
Vrstva kopírováním (Layer → 
New → Layer Via Copy).

3. Ve vrstvě bude jen úzký, hně-
dý, proužek. Zvolte příkaz 
(Edit → Free Transform). 
Kolem proužku se vytvoří 
transformační body. Tažením 
za body na svislých hranách roztáhněte proužek doprava i doleva na celou šířku doku-
mentu. Z hnědých skvrn se vytvoří různě široké hnědé vodorovné proužky. 

4. Vrstvu znovu upravte fi ltrem Houba (Sponge) nastaveným tentokrát na Velikost štětce 
(Brush Size): 10, Vyhraněnost (Defi nition): 4, Vyhlazení (Smoothness): 1. Vodorovné 
proužky se naruší malými skvrnami. Nakonec přidáme fi ltr Tahy štětce → Nastříkané 
tahy (Filter → Brush Strokes → Sprayed Strokes) nastavený na Délka tahu (Stroke Leng-
th): 20, Poloměr trysky (Spray Radius): 4, Směr tahů (Stroke Direction): Vodorovně 
(Horizontal) pro jemné, nepravidelné, zvlnění vodorovných proužků. 

5. Když nyní zapnete zobrazení všech vrstev, bude pozadí písmen tvořeno texturou dřeva. 

Jako malé vylepšení jsem do obrázku přidal několik mořských živočichů. Aby byli také proliso-
váni do písku, musíte je na začátku přidat do výběru, ze kterého vytváříte masku.
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Obrázek 5.87 Výsledný text v písku

Obrázek 5.86  Textura dřeva

Obrázek 5.85  Textura dřeva – proužky
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